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Introduction

The OSEK/ VDX ActiveX control implements the kernel awareness debugging of
OSEK applications for Seehau software using Nohau's RTOS interface. This
provides the debugging facility for OSEK applications running on Nohau's Emul-
12 PC (HC 12 processor family) emulator using Seehau software.

The OSEK / VDX ActiveX control analyzes the application specific information
from the ORTI file and integrates with Seehau for the internal OSEK OS data to
provide debugging facility for OSEK applications. The ActiveX control supports
both the ORTI break and trace interface.

The ActiveX control is developed based on ORTI specification version 2.1 and
Vector OS version 2.1.

In this document the OSEK / VDX ActiveX Control and OSEK Control are used
as synonyms.

Document organization and format

This document is organized into sections.

Section 1 - Introduction - Provides an overview of the manual. This section of
the Introduction summarizes the contents of the remaining sections and
appendices. The remainder of this section presents an overview of OSEK Control
and provides references to related documentation and technical support.

The following sections, if read sequentially, provide a step-by-step guide for
debugging OSEK applications using Seehau with OSEK Control.

Section 2 - Software Installation - Describes the software and hardware
necessary for successful installation and operation of the OSEK Control.

Section 3 — Getting started - Describes the steps to configure and use the
OSEK Control for debugging the OSEK applications.

Section 4 — OSEK Control features - Describes the features related to OS
Objects and Parameters that are available with OSEK Control.

Technical support

In U.S, technical support representatives are available to answer your questions.
You may also fax or e-mail your questions to us. Please include your [voice]
telephone number, for prompt assistance. Non-U.S. users may choose to contact
their local representatives.

Phone: (248) 488-2080

Fax: (248) 488-2082

E-mail: techsupp@dgtech.com
Web site: http://www.dgtech.com



http://www.dgtech.com/
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2 Software Installation

2.1 Installation Instructions

e Unzip the file “OSEKRelease.zip”.
¢ Click on Install.bat that registers the “OsekVdx Control” ActiveX control.

3 Getting started

e Make the necessary hardware connections for Seehau.
e Launch the Seehau application.

e Select “File->Load Code...” menu option from Seehau main window to load
the required OSEK application.

“E S eehau for EMUL12-PC

Macru Edit “iew MNew Hun Breakpointz Tools

Load Code ... I;'v e W
Yerify Loaded Code ... LY

Load Prexious J ’

Load Default CPU Sumbiols
Bemove Sombols
Show Load Info ..

r

Screen No. 1 — Load code

¢ Open the RTOS window by selecting “View->Real Time OS ...” menu option
from the Seehau main window.

“L Seehau for EMUL12-PC

File Macro Edit Mew Bun Breakpoint:
EE g Symbal Browser ...

LocalYariables ...

T Evaluate ... Chil+E
= H _vauag il+
— — — —  Breakpoints ...

Bzzembly |

Macros ..

Meszages ...
Real Time 05 ..

S EReg:..
Watch
Command Line Al+L

Screen No. 2 — Select Real Time OS

e Now, select “Select-> OsekVdx Control (ORTI 2.1)” menu option from the
RTOS window to bring up the OsekVdx Control window
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\"JReal Time 0S Hi=] E3

2 Oszelddw Contral [ORTI 2.1]
2 pCA05- Kemel Awareness
4 Ozeld'dw Control

5 RTA Osekidx Control

B RTOSDema Contral

¥ CEFAware Control

Screen No. 3 — Select OsekVdx Control

o |If a code is loaded before opening RTOS window, then “Action->Loaded”
menu option from the RTOS window should be selected.

e The OSEK / VDX ActiveX object will display all the objects and
corresponding attribute details that are specified in the input ORTI file. Each
Object will have dedicated window for displaying its specific attributes and
the information.

e The static attribute details of each object will be updated when the emulator
is stopped. The dynamic attribute details of each object will be updated when
the trace is stopped.

e The user will be given with the options to start and stop the trace as well as
emulator.

e From the RTOS window, select “Actions->Loaded” menu option. The static
information present in the OSEK application is shown in the corresponding tabs.

‘U Real Time DS IS[=] E3
File [P0l Select Help

En ¥ 2ty On Top Nohau for EMULT2-PC rams .ﬁ.nal}lsis—‘

Start | Stop |

E Rezet
Lo |

Emu Do Read Mem g Trace Stopped
Endian =10
E ndiar = 1 AT | STACK | vs_Event | aLaRM | RESOULA] * ]
_EIS Mame | RUMMINGTASE, | RUMMIMNGISR2 | SERVICETRE
512 _DP25E | bazicT azkT hird MO_ISH ActivateT azk

« | H

Screen No. 4 — Select Actions Loaded

e From the Seehau window select “Breakpoints->Add Breakpoint” to place
the break point at the required address.

Dearborn Group 4



OSEK / VDX DEBUG SUPPORT SOFTWARE MANUAL

Add Breakpoint |
DEFIME: Apply
File Mame IstSampIeFiIesHsample1 hzamplery. o
Line | Ok
OF: Cancel
Address IEIHEEIBH
* Software " Hardware Help

Screen No. 5 — Break point window

e Press “Go”. Now, the RTOS window is updated with the trace and breakpoint
interface data after it encounters breakpoint.

" Real Time 05 [_ (O] x|

File Actionz Select Help

bor——————— Haohau for EMULT 2-PC RTOS Analyziz
({ o Breakl ’7 Start | Stu:up_”

Ermulator Stopped Trace Stopped

Object! | Object2 | Object? | Object4 | Objects | TRACE |
Attribute Mame | Atribute? | Atiibute? | Atibute? | Attributed | ‘

Screen No. 6 — Press GO

3.1 OSEK / VDX control main window
o Select “Select—>0sekVdx Control” from the RTOS window to display
OSEK Control window
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{“JReal Time 05 M=l E3

File  Actionz Select Help
Emulatar——— Maohaw for EMULTZ-PC RTOS Analysis
’V Breakl ’V Start | St-:up_”

Emulatar Stopped Trace Stopped

Obiect! | Object2 | Obiect3 | Object4 | Objects | TRACE |
Attribute Mame | Attibute] | Atibute? | Attribute3 | Attributed |

Screen No. 7 — OSEK / VDX Control window
e “Go” button is used to start the Emulation of the program code.
e “Break” button is used to stop the Emulation of the program code.
e “Start” button is used to record the selected data into trace buffer.
o “Stop” button is used to stop recording the trace data.

o Status of the emulator is displayed (started, stopped) on the RTOS
window.

e The address, at which the emulation is stopped, displayed on the RTOS
window.

e Status of the trace is displayed (started, stopped) on the RTOS window.

4 OSEK Control Features

Note: The following OSEK control features are described using a sample file as
an example. The features described below are specific to the sample file.
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4.1 OS object Information
“CReal Time 05 M= &3

File Actionz Select Help
E mulatar ——— MNahau for EMULTZ2-FC RTOS Analysiz
= ey

Emulator Stopped at: 0xCO56E Trace Stopped

05 | Task | CONTEXT | STACK | vs_Evert| ALaRM | RESOULY |

05 Mame | RUNNINGTASE | BUNNIN... | SERVICETRACE | F
512 _DP2RE | basicTaskSeco..  WO_ISH FeleazeR ezource ‘

4] | i

Screen No. 7a — OSEK / VDX OS Information window

e The OS tab displays the OS object information.

e The OS window displays the various OS object attributes like OS Name,
RUNNINGTASK, RUNNINGISR, SERVICETRACE etc. that are defined

for the OS object in the OSEK application.

4.2 Task Information
‘"JReal Time DS =] E3
File Actionz Select Help
E mulatar ——— MNahau for EMULTZ2-FC RTOS Analysiz
5o | [eea] ey
Emulator Stopped at: 0xCO56E Trace Stopped

05 TASK | CONTEXT | STACK | vs_Evert| ALaRM | RESOUL4 |

TASK Mame | PRIORITY | ws HomePri.. | STATE | sTACK |
extendedT askF... 10 10 Wit TING ozl as...
edtendedT azk5...| 8 g SUSPEM... | osTas..
bagicTagkThird 12 12 SUSPEM...  osTas.
bazicTazkSeco.. | 2 2 RUMMIMG ozl as...
basicT azkFirst 1 1 READY ozl as...
<] | |

Screen No. 8 — OSEK / VDX Task Information window
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e The TASK tab displays the TASK object information.

o The TASK window displays the various TASK object attributes like TASK
Name, PRIORITY, vs_HomePriority, STATE etc. that are defined for the

TASK object in the OSEK application.

4.3 Stack Information

"L Real Time 05

File Actionz Select

I ahau far EMILTZ-PC

Emulator————
Lo ]

Emulatar Stopped at; DxCOBE

05 | TASK | CONTEXT STACK | vs Evert| ALaRM | RESOULS | |

Help

RTOS Analyziz
’V Start | Stu:np_‘l

I =] E3

Trace Stopped

STALCK. Marme

| sizE | BASEADDRESS | STACKDIRECTION

oz5pztenStack,
ozT askStackl
ozT azkStack]
o:T azkStack?
ozT askStack3
ozT askStackd

4]

0=50
0=50
0=50
=50
0=50
0=50

0=11FF
0:110F
0=114F
0x115F
0=10BF
0:10EF

DOk
DOk
DOwH
DO
DOk
DOk

2

Screen No. 9 — OSEK / VDX Stack Information window

e The STACK tab displays the STACK object information.

e The STACK window displays the various STACK object attributes like
STACK Name, SIZE, BASEADDRESS, STACKDIRECTION etc. that are
defined for the STACK object in the OSEK application.
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4.4 Vs_Event Information

"I Real Time 0% [_ [O] x|

File Actionz Select Help
E mulatar ——— MNahau for EMULTZ2-FC RTOS Analysiz
= ey

Emulator Stopped at: 0xCO56E Trace Stopped

05 | TaSK | CONTEXT | STaCK  vs_Evert | aLamM | RESOULY | ]

vz Ewvent Mame | vz Ewenthdazk, |
evExT1_1 Q0001
evErT2 1 0001

Screen No. 11 - OSEK / VDX vs_Event information window
e The vs_Event tab displays the vs_Event object information.

o The vs_Event window displays the various vs_Event object attributes like
vs_Event Name, vs_EventMask etc. that are defined for the vs_Event
object in the OSEK application.

4.5 Alarm information
‘"I Real Time DS _ (O] <]
File Actionz Select Help
Ernulator——— Mahau for EMULT2-PC RTOS Analysis
(oo | (et S| s
Ermulator Stopped at: OxCCEF Trace Stopped
vs_Event ALARM | RESOURCE | vs_0S_Corfig | TRACE | |+
ALARM Mame | CYCLETIME | vs CycleTime . | ALARMTIME | vs
myFirzkdlarm =00 =00 w32 s
1] | a

Screen No. 12 - OSEK / VDX Alarm information window
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e The ALARM tab displays the ALARM object information.

o The ALARM window displays the various ALARM object attributes like
ALARM Name, CYCLETIME, ALARMTIME etc. that are defined for the
ALARM object in the OSEK application.

4.6 Trace Information

{“JReal Time 05 [_ (O] x|

Eile Actions Select Help
Emulator———— MNahau for EMULTZ2-PC RTOS Analysis
(oo | (e | s |

Emulator Stopped at: 0xCC3F Trace Stopped

vs_Event | ALARM | RESOURCE | vs_0S_Config { THACEY] ]
Tazk / Service Graph

Service Coverage

Application Analyziz

Screen No. 13 — OSEK / VDX Trace information window

This module displays the graphical representation of the “Task / Service
Graph”, “Service coverage” and “Application Analysis” of the OSEK / VDX
application after the data has been recorded in the trace buffer.

Refer: Section [4.6], Screen No. 13
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4.7 Task / Service graph

‘L Tazk / Service Graph

Rezalution | 1 -

=] E3

Time |25.00 uzec

BO7ED2 s BOTYE

T3
TASK LIST

IDLETASE.

5076125 5076175 5076225 5076275 G07632s G0TEI—

:

extendedT askFirst

p extendedT askSecond

b bazicTazkThird

b bazicT azkSecond

bazicT azkFirst

e ActivateT azk

il

[
o

Screen No. 14 — OSEK / VDX Task/Service graph window showing the

il Task / Service Graph

R ezalution | -

task information

IS [=] E3

Time |25.00 usec

B076R02 s  5.0TH

T3

SERYICE LIST

e ActivateT azk

AO7R12s 507R1Ys BOTRZZs 50F62Ts HOTR3Es E.IIIT"I33ﬂ

|e TeminateT azk,

|9 ChainT ask

|e [3etT azkState

|9 GetFRezource

9 FeleazeRezource

.
@ SetEvent i
9 ClearE vent B & ﬂ
Kal ]

Screen No. 14a — OSEK / VDX Task/Service graph window showing the
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The Task / Service graph window shows the graphical representation of task
and service switching times. Refer: Section [4.7], Screen Nos. 14 and 14a.

o All the Tasks and Services (services that have become active during the
trace data capture) are sown on the left hand side of the graph. The
Tasks are represented with letter “T” and the services are represented
with the letter “S”.

e The latest Task / Service that is ON (active) is shown with

e The blue color lines show the task switching and the black color lines
show service switching timings

o Thick lines represent task / service ON (active) period
e Thin lines represent task OFF (inactive) period

e The cursors can be moved on the graph (by selecting and dragging with
mouse) to measure the time difference. The Time text box displays the
exact time difference between the cursors.

¢ The Resolution selection box can be used to set the resolution for time
scale at x1, x10, x100 and x1000 factors to scale the display.

4.8 Service coverage
iU Service Coverage H=]
Service OM Time | Count | Awg OM Time Fatio | 0 10 20 30 40 50 60 70 &L
ActivateT azk, 0.023809 ms B 0.004301 ms B102541% e
TeminateT agk, 0.093750 ms B 0015625 ms: 19858837 % ——
ChainT ask. 0.030273 ms 2 005137 ms EA412667 % e
GetTazkState 0021484 ms 4 0.005371 ms 4550504 %  =m
GetResource 0016113 ms 4 0.004028 mz 31NN E m
FeleazeResource 0073242 ms 4 083 T me . 15514677 % e—
SetEvent 0.0E7297 ms B 0011216 ms 14255361 % | =
ClearEvent [.026367 ms B 0.004395 ms REERZAEE =
W aitE went 0114746 ms B 009124 m: 24306365 % | m—
4] | N
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Screen No. 15 - OSEK / VDX Service coverage window

The Service Coverage window shows the following statistics of the services

e The total ON time of a service.

e The count, which shows number of times each service became active.

e The average ON time of a service.

o Graphical representation of the percentage average ON time.

Refer: Section [4.8], Screen No. 15
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4.9 Application Analysis

Tazk / Service Time -
9 Cleark vent BO076.021973 ms J
9 GetT azkState B07E.057129 ms

9 ActivateT azk, RO7E.075195 ms

9 W it vent ROYE. 105957 mz

0 extendedT azkSecond ROVE 113770 mz

9 W aEitE vent RO7E.143926 mz

0 bazicT azkFirst RO7RIG7227 mz

&  GetResource RO76.199219 ms

9 ActivateT azk B076.214844 ms

9 ReleazeR ezource B07E.251953 ms

0 bazicT azkSecond RO7E. 259766 ms

o MO_TASE RO7E. 273809 mz ll
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Screen No. 16 — OSEK / VDX Application Analysis window

The Application Analysis window shows the application snapshot in the text

format. Application Analysis window includes the following parameters

e Task/ Service

e Time

Dearborn Group
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